Discussion:
transient error with new LaTeX/inputenc: needed to rebuild formats myself
(too old to reply)
jfbu
2018-04-10 13:03:52 UTC
Permalink
Hi,

this morning I got an error with

\documentclass{article}

\usepackage[utf8]{inputenc}

\begin{document}

% nothing here

\end{document}

! LaTeX Error: File `uf8.def' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: def)

I had updated the TL2018 pretest minutes before.

(last update was at some unknown date in past)

This disappeared after rebuilding the formats via

fmtutil-sys --all

I wonder why that was necessary,

Best

Jean-François
jfbu
2018-04-10 13:12:47 UTC
Permalink
Post by jfbu
I wonder why that was necessary,
I mean why it was not triggered automatically after the update via tlmgr update --all
jfbu
2018-04-10 13:24:52 UTC
Permalink
Post by jfbu
Hi,
this morning I got an error with
\documentclass{article}
\usepackage[utf8]{inputenc}
\begin{document}
% nothing here
\end{document}
! LaTeX Error: File `uf8.def' not found.
Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: def)
I had updated the TL2018 pretest minutes before.
(last update was at some unknown date in past)
the unknown date was yesterday

[Mon Apr 9 14:09:53 2018] update: latex (43813 -> 47377)


then today

[Tue Apr 10 11:20:14 2018] ...
(no latex update today)

J.-F.
Post by jfbu
This disappeared after rebuilding the formats via
fmtutil-sys --all
I wonder why that was necessary,
Best
Jean-François
Loading...