Discussion:
biber and biblatex incomaptible
(too old to reply)
Uwe Siart
2017-11-05 12:35:22 UTC
Permalink
After today's update there's an incomaptibility between biber and
biblatex that prevents working with biber at all. Here's what I get on
the command line (win32):

d:\>biber testfile
INFO - This is Biber 2.7
INFO - Logfile is 'testfile.blg'
INFO - Reading 'testfile.bcf'
ERROR - Error: Found biblatex control file version 3.4, expected version 3.3.
This means that your biber (2.7) and biblatex (3.8) versions are incompatible.
See compat matrix in biblatex or biber PDF documentation.
INFO - ERRORS: 1
--
Uwe
Petra Ruebe-Pugliese
2017-11-05 12:57:27 UTC
Permalink
Hello,
Post by Uwe Siart
After today's update there's an incomaptibility between biber and
biblatex that prevents working with biber at all. Here's what I get on
d:\>biber testfile
INFO - This is Biber 2.7
INFO - Logfile is 'testfile.blg'
INFO - Reading 'testfile.bcf'
ERROR - Error: Found biblatex control file version 3.4, expected version 3.3.
This means that your biber (2.7) and biblatex (3.8) versions are incompatible.
See compat matrix in biblatex or biber PDF documentation.
INFO - ERRORS: 1
CTAN received yesterday night an update of biblatex to Version 3.8.
The comment said that this required biber 2.8 .

However, AFAICS biber has not yet been updated on CTAN.

Moreover, we received this morning a re-upload of a "corrected
biblatex 3.8" that was still labelled "3.8".

I asked for a re-upload of the same, but with a slightly
increased version number, to avoid confusion.
At the moment, we have not got any further.

Therefore I'd recommend, for the time being, that TeX Live
revert to biblatex 3.7.

Petra (from CTAN)
Rémy Oudompheng
2017-11-15 22:45:02 UTC
Permalink
Post by Petra Ruebe-Pugliese
Hello,
Post by Uwe Siart
After today's update there's an incomaptibility between biber and
biblatex that prevents working with biber at all. Here's what I get on
d:\>biber testfile
INFO - This is Biber 2.7
INFO - Logfile is 'testfile.blg'
INFO - Reading 'testfile.bcf'
ERROR - Error: Found biblatex control file version 3.4, expected version 3.3.
This means that your biber (2.7) and biblatex (3.8) versions are incompatible.
See compat matrix in biblatex or biber PDF documentation.
INFO - ERRORS: 1
CTAN received yesterday night an update of biblatex to Version 3.8.
The comment said that this required biber 2.8 .
However, AFAICS biber has not yet been updated on CTAN.
Moreover, we received this morning a re-upload of a "corrected
biblatex 3.8" that was still labelled "3.8".
I asked for a re-upload of the same, but with a slightly
increased version number, to avoid confusion.
At the moment, we have not got any further.
Therefore I'd recommend, for the time being, that TeX Live
revert to biblatex 3.7.
Petra (from CTAN)
Hello,

The new biblatex version (\def\***@version{3.8a}) breaks tex4ht because
tex/generic/tex4ht/biblatex.4ht performs tests like :
\ifdim\***@version pt< 3pt
or \ifdim\***@version pt< 3.3pt
which break with a "Illegal unit of measure" error.

Should it be fixed in biblatex or tex4ht ?

Regards,
Rémy.
Karl Berry
2017-11-05 23:52:05 UTC
Permalink
Therefore I'd recommend, for the time being, that TeX Live
revert to biblatex 3.7.

How unfortunate. Ok, I think that is done for tonight. We'll see if I
just made things worse with my attempted reversion ... --thanks, karl.
Karl Berry
2017-11-15 22:49:49 UTC
Permalink
tex/generic/tex4ht/biblatex.4ht performs tests like :
\ifdim\***@version pt< 3pt
or \ifdim\***@version pt< 3.3pt
which break with a "Illegal unit of measure" error.

Should it be fixed in biblatex or tex4ht ?

tex4ht, surely. I'll tell Michal.

Loading...