Discussion:
tlmgr update dry-run
(too old to reply)
Philipp
2018-01-22 17:35:10 UTC
Permalink
Hi,

I'm a bit confused by the --dry-run option for tlmgr update

I just ran "tlmgr update --all --require-verification --dry-run" and got

tlmgr.pl: package repository
http://ftp.gwdg.de/pub/ctan/systems/texlive/tlnet (verified)
tlmgr.pl update: dry run, no changes will be made
tlmgr.pl: saving backups to C:/texlive/2017/tlpkg/backups
[1/8, ??:??/??:??] update: luatexja [3553k] (45761 -> 46405)
[2/8, 00:00/00:00] update: pm-isomath [600k] (46012 -> 46402)
[3/8, 00:00/00:00] update: texlive-scripts [118k] (46306 -> 46398)
[4/8, 00:00/00:00] update: thesis-gwu [504k] (46114 -> 46403)
[5/8, 00:00/00:00] update: tlcockpit [12705k] (46392 -> 46406)
[6/8, 00:00/00:00] update: toptesi [5041k] (46074 -> 46404)
[7/8, 00:00/00:00] auto-install: fancyhandout (46401) [74k] ... [8/8,
00:00/00:00] update: collection-latexextra [6k] (46213 -> 46401)

Directly afterwards, I ran "tlmgr update --all --require-verification"
(i.e. the same command without the --dry-run option) and got
tlmgr.pl: package repository
ftp://ftp.tu-chemnitz.de/pub/tex/systems/texlive/tlnet (verified)
tlmgr.pl: saving backups to C:/texlive/2017/tlpkg/backups
tlmgr.pl: no updates available

So it looks to me as if either the updates where installed with the
first run despite the --dry-run option, or the option prevents the
updates from being found (again) when --dry-run is omitted afterwards.

Am I doing something wrong here, or is this a bug?

Regards,
Philipp
Philip Taylor (RHUoL)
2018-01-22 17:58:24 UTC
Permalink
Post by Philipp
tlmgr.pl: package repository
http://ftp.gwdg.de/pub/ctan/systems/texlive/tlnet (verified)
tlmgr.pl: package repository
ftp://ftp.tu-chemnitz.de/pub/tex/systems/texlive/tlnet (verified)
Is it possible that the two repositories are not in synch ?
Philip Taylor
Philipp
2018-01-22 18:40:20 UTC
Permalink
Post by Philip Taylor (RHUoL)
Is it possible that the two repositories are not in synch ?
Philip Taylor
Thank you, this seems to have been the issue. I ran the command again,
and now the updates where found again.
I didn't think of this possibility.

Regards,
Philipp

Loading...