Discussion:
Ghostscipt related problems with psv
Add Reply
Alois Steindl
2018-11-29 12:20:43 UTC
Reply
Permalink
When I try to view any pdf- or postsciptfile with psv, I get the error
message
GPL Ghostscript 9.25 (2018-09-13)
Copyright (C) 2018 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
This is wxLuaGhostscscript.
Lua: Error while running chunk
E:\texlive\2018\tlpkg\tlpsv\psv.wx.lua:1535: attempt to index field
'image' (a nil value)
    E:\texlive\2018\tlpkg\tlpsv\psv.wx.lua:1535: in function 'PushRunGS'
    E:\texlive\2018\tlpkg\tlpsv\psv.wx.lua:1656: in function
<E:\texlive\2018\tlpkg\tlpsv\psv.wx.lua:1654>
For me this happens on two quite new notebooks with Win10, both have
installed TeXLive.

Is the problem known and is there maybe a fix for it?

(In Linux I encountered problems with the new gs 9.25, with doesn't
cooperate with my favorite viewer, the outdated gsview 4.9; so I keep an
older gs 9.22 at these notebooks in order to be able to further use
gsview 5.0; I cannot use the new one.)

Best wishes

Alois
Akira Kakuto
2018-11-29 22:03:13 UTC
Reply
Permalink
GPL Ghostscript 9.25 (2018-09-13)
... ...
In the case of the present Ghostscript 9.26,
I obtain a different error on Windows 7:

**** Unable to open the display device, quitting.

I found that the message is a fatal error message
in idisp.c in Ghostscript.

Thus I suspect that the psv is not compatible with
the Ghostscript 9.25 and Ghostscript 9.26.

Best,
Akira
Alois Steindl
2018-11-30 15:14:54 UTC
Reply
Permalink
Thank you very much for your response!
I just tried out the psv-version from TeXLive 2017 and obtained the
message below.
In case of the problems between gs 9.25 and Gsview 5.0 I thought, that
it is just a case of an old program like Gsview not being updated.
(Ghostscript itself works fine, but it seems to me, that there is passed
somehing from GSview to gs, which blocks the proper search for the
resources.)
In this case I assumed, that psv would be actively maintained and such a
behaviour should have be detected quite soon; so I am still not sure,
that the culprit isn't somewhere in the setup of the computer. (In my
case the culprit most of the time sits in front of the computer.)
Can anyone use a recent version of psv without problems?
With kind wishes
Alois
GPL Ghostscript 9.22 (2017-10-04)
Copyright (C) 2017 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
 *** WARNING - the DELAYBIND command has been deprecated, and will be
               removed in the next version. For now you can restore
               the behaviour by using -dREALLYDEALYBIND but if you
               require continued use of this command you should contact
               the Ghostscript developers. Commercial customers of
               Artifex should email their support contact, free users
               are encouraged to talk to us on the #ghostscript IRC
               channel on irc.freenode.net.
Unrecoverable error: undefined in DELAYBIND
This is wxLuaGhostscscript.
Lua: Error while running chunk
E:\texlive\2017\tlpkg\tlpsv\psv.wx.lua:1511: Ghostscript konnte nicht
gestartet werden
    [C]: in function 'error'
    E:\texlive\2017\tlpkg\tlpsv\psv.wx.lua:1511: in function 'StartGS'
    E:\texlive\2017\tlpkg\tlpsv\psv.wx.lua:2230: in function 'Main'
    E:\texlive\2017\tlpkg\tlpsv\psv.wx.lua:2242: in main chunk
Akira Kakuto
2018-12-01 09:41:48 UTC
Reply
Permalink
Post by Alois Steindl
In case of the problems between gs 9.25 and Gsview 5.0
I thought, that it is just a case of an old program like
Gsview not being updated.
The Windows version of Gsview 5.0 works with gs-9.25 and
with gs-9.26 by the following setting:

(1) Uncheck Options--->Safer
(2) Add -dSAFER in
Options--->Advanced Configure...--->Ghostscript Options:
instead of Options--->Safer

Best,
Akira
Akira Kakuto
2018-12-01 10:10:00 UTC
Reply
Permalink
Post by Akira Kakuto
The Windows version of Gsview 5.0 works with gs-9.25 and
(1) Uncheck Options--->Safer
(2) Add -dSAFER in
instead of Options--->Safer
The above refers to a gs binary compiled with COMPILE_INITS=0.
If compiled with COMPILE_INITS=1, the Windows version of
Gsview 5.0 works with the default setting.

Best,
Akira

Loading...